Probleme beim Rooten des Shift7+

Hilfestellungen, Troubleshooting, ...
Antworten
Benutzeravatar
detlefr
SHIFTPHONES Team
Beiträge: 2618
Registriert: Fr 6. Feb 2015, 18:59

Re: Probleme beim Rooten des Shift7+

Beitrag von detlefr » Do 1. Dez 2016, 19:42

Ich weiß es nicht, aber trenn es doch einfach mal und sieh was ist. Du kannst das ganze ja wiederholen.
-------------------------------------------------
detlef@shiftphones.com
Skype: detlefr123


Zum SHIFTPHONES Newsletter könnt ihr euch hier:
https://www.shiftphones.com/newsletter-signup/
anmelden.

Benutzeravatar
Dinkster
Beiträge: 26
Registriert: Mi 1. Jul 2015, 15:51
Kontaktdaten:

Re: Probleme beim Rooten des Shift7+

Beitrag von Dinkster » Fr 2. Dez 2016, 06:01

Ich hab es jetzt mehrere Male versucht und werd nun wohl aufgeben.

Wenn ich es abbreche, also das Kabel abziehe z. B., dann bekomm ich beim nächsten Versuch ne Meldung, dass es nicht mehr erlaubt ist:

"FAILED (remote: download for partition 'recovery' is not allowed)"

Erst nach normalem Start und anschliessendem Start ins "fastboot" kann ich es erneut probieren.

Aber dann bleibt das Terminal und das Shift wieder ewig im gleichen Modus:

- das Shift: USB transferring...
- Terminal:
terminal_2.png
terminal_2.png (28.42 KiB) 437 mal betrachtet

Benutzeravatar
HannsDieter
SHIFTPHONES Team
Beiträge: 475
Registriert: Fr 6. Feb 2015, 18:58

Re: Probleme beim Rooten des Shift7+

Beitrag von HannsDieter » Fr 2. Dez 2016, 14:57

Der sending... Fehler scheint wohl häufiger vorzukommen.
Versuche es mit einem anderen USB-Port und/oder einem anderen USB Kabel.

Benutzeravatar
Dinkster
Beiträge: 26
Registriert: Mi 1. Jul 2015, 15:51
Kontaktdaten:

Re: Probleme beim Rooten des Shift7+

Beitrag von Dinkster » Fr 2. Dez 2016, 19:02

3 Kabel ausprobiert. 2 USB-Ports...
Bildschirmfoto_2016-12-02_18-54-47.png
Bildschirmfoto_2016-12-02_18-54-47.png (46.75 KiB) 425 mal betrachtet
:-(

Benutzeravatar
HannsDieter
SHIFTPHONES Team
Beiträge: 475
Registriert: Fr 6. Feb 2015, 18:58

Re: Probleme beim Rooten des Shift7+

Beitrag von HannsDieter » Sa 3. Dez 2016, 15:03

Da hat das Senden ja geklappt.

Du scheinst keinen Zugriff auf die recovery Partition zum Schreiben zuzulassen.

Gehe in die Developer options (Settings->About Phone->Build Number klicken bis Developer options eingeschaltet sind; Settings->Developer Options) und aktiviere OEM unlocking

Gib dann vor dem flashen noch "fastboot oem unlock" ein. Jetzt sollte es aber klappen :D

(Nach dem Flashen keinen normalen reboot zulassen, sondern direkt in das recovery booten)

Benutzeravatar
Dinkster
Beiträge: 26
Registriert: Mi 1. Jul 2015, 15:51
Kontaktdaten:

Re: Probleme beim Rooten des Shift7+

Beitrag von Dinkster » Mo 5. Dez 2016, 06:39

Hallo Hans-Dieter,

Danke für die Tipps.

Das OEM-Unlock hat erst funktioniert, nachdem ich es in den Entwickler-Einstellung aktiviert und gleich danach in’s Recovery neugestartet hatte. Mit normalem Neustart vergisst das Shift immer diese Einstellung und setzt sie zurück.

Dann also hat der Befehl mit "fastboot oem unlock funktioniert"

Und die "recovery.img" kopieren hat auch funktioniert.

Danach hab ich "fastboot reboot" eingegeben und gleich die Plus-Taste gehalten.

Ich kam aber aus dem Modus "<Waiting for devices>" nicht raus. Also hab ich irgendwann das manuel mit Einschaltknopf-Plustaste abgebrochen.

Danach bin ich den Cyanogen-Recovery-Bereich reingekommen.

Nach dem ich "Apply Update" auswähle kam ich aber nach "Choose from internal..." nicht weiter.

Hier hänge ich jetzt:
2016-12-05_um_07-19-38.jpg
2016-12-05_um_07-19-38.jpg (65.92 KiB) 413 mal betrachtet
Schritt für Schritt komme ich wohl dem kompletten "Reset" nahe... ;-)

Benutzeravatar
detlefr
SHIFTPHONES Team
Beiträge: 2618
Registriert: Fr 6. Feb 2015, 18:59

Re: Probleme beim Rooten des Shift7+

Beitrag von detlefr » Mo 5. Dez 2016, 11:40

Was hast du denn da für ein recovery? Für das 7+ ist im wiki ein TWRP recovery, das sieht anders aus.
-------------------------------------------------
detlef@shiftphones.com
Skype: detlefr123


Zum SHIFTPHONES Newsletter könnt ihr euch hier:
https://www.shiftphones.com/newsletter-signup/
anmelden.

Benutzeravatar
Dinkster
Beiträge: 26
Registriert: Mi 1. Jul 2015, 15:51
Kontaktdaten:

Re: Probleme beim Rooten des Shift7+

Beitrag von Dinkster » Mo 5. Dez 2016, 14:49

Das Recovery hab ich von hier: http://de.shiftphones.com/wiki/SHIFT7%2B/FAQ/Rooten

Sieht bei mir – bis zur Fehlermeldung – auch genauso aus wie im Video.

Benutzeravatar
detlefr
SHIFTPHONES Team
Beiträge: 2618
Registriert: Fr 6. Feb 2015, 18:59

Re: Probleme beim Rooten des Shift7+

Beitrag von detlefr » Mo 5. Dez 2016, 15:47

Das Recovery ist auch in Ordnung. Ich hatte vergessen das TWRP Recovery einzubinden. Geh nochmal zu der Seite und lade es runter. Du musst aber die zip Datei vorher entpacken, da da auch noch eine scatter Datei mit bei ist, die du für das Flashtool für Windows benötigst. Das darfst du nicht mit flashen, wenn du es über fastboot machst.
-------------------------------------------------
detlef@shiftphones.com
Skype: detlefr123


Zum SHIFTPHONES Newsletter könnt ihr euch hier:
https://www.shiftphones.com/newsletter-signup/
anmelden.

Benutzeravatar
Dinkster
Beiträge: 26
Registriert: Mi 1. Jul 2015, 15:51
Kontaktdaten:

Re: Probleme beim Rooten des Shift7+

Beitrag von Dinkster » Mo 5. Dez 2016, 16:45

Ich "flashe" unter Ubuntu. Und nur die recovery.img. Nicht die ZIP-Datei.

Die Scatter-Datei liegt ja extra im Ordner, nachdem ich das ganze entpackt habe. Mit der kann ich ja unter Ubuntu per "fastboot" nichts anfangen. Das war/ist mir soweit schon klar ...

Also lad ich mir die ZIP-Datei nochmal neu ausm Wiki und starte den Flash-Vorgang mit dem Inhalt erneut? Denn da ist jetzt die richtige "recovery.img" mit dabei?

Antworten