SHIFT7 Erfahrungen flashen, Speicheraufteilung, rooten

Status
Not open for further replies.

dirkw

Active member
Feb 8, 2015
184
Hier mein Erfahrungsbericht - ich fang mal mit dem Fazit an: Es hat geklappt!

Ich als Android-Neuling hatte doch erhöhten Puls bei der Sache... zuerst hab ich auf meinem Shift7 die Apps mit einem meiner Lieblings-Apps "All in one Toolbox" (Link: https://play.google.com/store/apps/deta ... olbox.full) auf die 64 GB SD-Karte gesichert (das Backup ist im Menüpunkt "Toolbox" zu finden).

Zu erst die Treiber installiert - da ich Win7 64bit hab, konnte ich die Vorbereitungen für Win8 überspringen und den Treiber direkt und einfach installieren wie im Videoclip Flashen (Teil2) beschrieben.

Wichtig ist wirklich, sich Schritt für Schritt genau an das Video zu halten - ich als Anfänger hab zusätzlich die Dateinamen und (sofern ersichtlich) die Dateigrößen mit denen im Videoclip verglichen (sicher ist sicher).

Das Stockrom aufspielen und die Speicherverwaltung ändern ging ganz easy (genau wie im Videoclip Flashen (Teil3) beschrieben).

Dann das Rooten, wo ich am meisten Bauchschmerzen hatte... zuerst mal hab ich einen Fehler gemacht. Detlef hat ja im Clip draufhingewiesen, dass USB-Debugging aktiviert sein muss... ich Schlaumeier erinnerte mich, dass ich das USB-Debugging persönlich aktiviert hatte, dachte aber nicht dran, dass durch das Stockrom aufspielen, das USB-Debugging (standardmäßig) wieder de-aktiviert war.

Dann ein Punkt, wo im Videoclip nicht hingewiesen wurde und weshalb ich vor dem eigentlichen Rooten fast gescheitert wäre. Jedes Mal als ich RootGenius_en.exe (Link von Detlef ein paar Postings weiter oben) starten wolle, kam die Fehlermeldung, dass ein schwerer Fehler aufgetreten ist und RootGenius beendet wird.

Auf den Grund bin ich selbst draufgekommen - RootGenius verlangt anscheinend eine vorhandene Internet-Verbindung. Dann funktionierte es.

Nach 25% (etwa 5 min) kam bei mir der im Videoclip zu sehende Fehlermeldungs-Bildschirm "Your phone ist so solid to root". Ich hab das Shift7 abgehängt und gestartet und keine KingUser-App vorgefunden - der erste Versuch hat also fehlgeschlagen.

Gleich nochmal mit Rooten probiert, dann ging's bei mir sogar bis 85%, bis die Meldung gekommen ist. Shift7 wieder abgehängt, runtergefahren und neu eingeschaltet... jetzt ist es gerootet - die KingUser-App war da und nach Starten dieser zeigt sich, dass das Rooten funktioniert hat.

Jetzt versuche ich noch, die All in One Toolbox zu installieren, mittels WLAN diese dann upzudaten (damit sie den gleichen Stand von gestern hat, als ich das App-Backup gemacht hab) und dann - hoffe es klappt - die Apps wiederherzustellen.

So weit mein Bericht - da ich als Neuling doch ein etwas mulmiges Gefühl hatte, damit sich andere Neulinge auch drüber trauen.

PS: Beim Speicher ist mir schon mal positiv aufgefallen, dass jetzt über 5 GB Speicher frei sind (anstatt vorher nur ca. 500 MB) - Platz für Apps und Games ohne Ende.
 

Heike Wi

Active member
Feb 13, 2015
116
Münster
Lieber Dirkw - du hast mir echt Mut gemacht, sodass ich das als Neuling mit meinem allerersten Smartphone (dem Shift) auch probiert habe - und: 3 Tage nach meiner flashen/rooten-Aktion funktioniert mein SHIFT7 immer noch prima!
Ich habe mir den Prozess beim 2.Versuch dokumentiert in Schriftform (Word-Datei), für den Fall, dass ich das nochmal machen müsste oder die Doku jemandem zur Verfügung stellen könnte.

Ein allerherzlichstes Danke-schön an Detlefr - der sicher endlos viele Stunden damit verbracht hat, dass alles für uns auszuprobieren und dann in eine Anleitung zu packen - plus seine Geduld und sein Tüfteln zum Beantworten unserer Fragen (nicht nur im "Shift 7 Rooten" & "Stockrom"-Faden).

Das Wichtigste vorab: Als ich abends endete mit erst einem gruseligen reboot-Menu (wie nach abgestürzten Laptop) :shock: und später einem "toten" Android-Männchen auf dem Screen mit "kein Befehl" (die Vol-Tasten scrollten nur, aber kein "Enter" möglich) und zum Schluss nur noch kurz dem Shift-Schriftzug auf dem Display beim Neustart :( - da dachte ich, ich müsse das Gerät jetzt wohl doch einschicken... :?

:idea: Aber nein: man fängt einfach noch mal neu an bei mit dem Flashtool ! Und wenn der Download mit der Scatter-Datei nicht gleich klappt, nicht blass werden: dann nochmal Akku raus & rein, damit man sicher geht, dass das Gerät auch wirklich aus ist (das war nach dem End-screen nicht mehr erkennbar gewesen).

Missgeschick 1: Ich hatte beim ersten Versuch übersehen, die Dateien zu entpacken (hatte ich eine Ahnung, wie man das macht??! - bis ich das Angebot im rechten Maustasten-Menü fand). Die habe ich erstmal in neu-angelegte Ordner entpackt, zusammen mit den zugehörigen Anleitungen, den Schritten entsprechend.
Missgeschick 2: nach dem ersten Durchgang gestartet - und erstmal WLAN wieder eingerichtet - da kam eine Meldung, dass der "Drahtlose Updater" eine neue Version hätte - natürlich erstmal draufgeklickt. Noch bevor ich das Google-Konto eingerichtet hatte (verwunderlich), erfolgte ein Fehlinstallation und schließlich landete ich bei oben geschilderten "bösen" Ende. Davor habe ich mich gehütet beim 2. Durchgang: Das OTA-Update, was wir zu Beginn gemacht haben (falls wir das Gerät nicht schon upgedatet ausgeliefert bekamen) muss nicht nochmal installiert werden.
Missgeschick 3: Beim 2. Versuch bekam ich die Treiber nicht installiert: weil ich das Gerät noch drinstecken hatte und der Gerätemanager unter Laufwerke 2 SHIFT7 anzeigte und unten ein YunOS-Phone mit ABC Interface. Ich hatte nicht realisiert, dass a) das Gerät noch an war und b) die Treiber noch erfolgreich installiert gewesen waren... Also Akku raus und gleich weiter mit dem Flashtool.

Tipp 4: die Flashtool-Aktion kann man öfter probieren mit rausziehen, ausmachen und reinstecken - nicht gleich resignieren - beim 3.Mal klappte der Download.
Missverständnis 5: ich hatte einiges überhört bzw. überlesen: a) hoppla - das mit dem Debugging vergessen b) Ja, der interne Speicher war jetzt 5,87GB - und der graue USB-Speicher unten - soll ich auf das Löschangebot klicken?? - Nein. einfach ignorieren, bis Detlefr uns was anderes sagt ;) . Also los mit Rooten. Das hat bei mir auf Anhieb geklappt bis zum "Retry"-Button - den man ja auch ignoriert.
Missverständnis 6: Vor dem drahtlose-Updates-Updaten habe ich mich gehütet - da tauchte die nächste Horrormeldung auf: "Damaged USB-Speicher ist beschädigt" "Die SD-Karte ist vielleicht beschädigt - wollen sie sie formatieren oder abbrechen?" Neeeiin- da sind doch meine BackUps drauf!! Diese Fehler-Benachrichtigung ist bisher noch nicht verschwunden - (vielleicht sagt Detlefr hier noch was dazu - vielleicht doch den grauen 5,87GB-USB-Speicher löschen?...)

Vorsichtshalber habe ich die Einstellungen USB-Debugging für Computergesteuerte Anwendung wieder deaktiviert und die Entwickleroptionen ausgestellt (solange ich keine Ahnung habe, wozu ich das brauchen sollte).

BackUps: hier muss ich gestehen, dass nix davon geklappt hat. Ich hatte vorher mit 4 Tools BackUps auf der SD-Karte gespeichert: "My BackUp" (Ordner rerware - wo man zum Wiederherstellen die ProVersion brauchen sollte), "All in one toolbox", "Android Assistant" und "Ultimate BackUp". 1 Ordner konnte ich nicht zuordnen (vielleicht vom Ultimate?). Ich habe nacheinander jede App installiert und jeweils auf Wiederherstellen geklickt - aber es wurden jedes mal nur die vorinstallierten Apps installiert und geupdatet - bei keinem erschienen meine zusätzlich heruntergeladenen Apps.
Vielleicht bin ich nicht versiert genug dafür - ich habe mir meine Apps aus der vorher angelegten Lesezeichenliste im Browser zu Fuß wieder installiert und eingerichtet.

Die vorher exportierte Kontaktliste war das einzige was prima funktionierte mit dem Re-Importieren (eine vcf-Datei) - am besten bei rausgezogener SIM-Karte.
 

dirkw

Active member
Feb 8, 2015
184
@Heike: Die "All in One Toolbox" hat nicht funktioniert beim Backup?

Das wundert mich, denn bei mir hat es perfekt funktioniert. Ich hab vor dem Flashen die All in One Toolbox gestartet, unter Toolbox das Backup gemacht für alle Apps, die aufgelistet wurden (ganz unten ist ein Kästchen, wenn man das anklickt, werden alle Apps ausgewählt).

Es wurde bei mir gleich richtig auf die SD-Karte gesichert und nach dem Rooten und Verändern der Speicheraufteilung hab ich ebenso in der Toolbox das Wiederherstellen der Apps gemacht. Es hat eine Zeit lang gedauert, alle Apps wiederherzustellen (ich glaub, 30 Minuten dürfte hinkommen), dafür hat alles perfekt funktioniert und mir viel, viel Zeit erspart, wenn ich sonst alle Apps neu installieren hätte müssen.

Du hast die Apps schon gesichert, bevor du das Stockrom aufgespielt hast? ;) Sonst wären die Apps ja weg gewesen und es hätte logischerweise nichts mehr zu sichern gegeben.
 

Heike Wi

Active member
Feb 13, 2015
116
Münster
@Dirk - ich wollte keinen entmutigen - erstmal hatte ich eine Weile gebraucht zu kapieren, dass das dauert und woran man das erkennt: neben den Haken taucht "installiert" auf - aber nach den installierten Standard-Apps ging es nicht weiter. Vielleicht habe ich auch nicht lange genug abgewartet. Gut zu wissen, dass es durchaus funktionieren kann.

Falls sich Neulinge in diesem Faden fragen, wo denn die Anleitungen sind: Detlefs Hinweis auf die Video-Anleitungen im Youtube-Channel "shiftphones Supporter" war in der Rubrik Ankündigung hier: da steht das auch mit den zu ignorierenden Meldungen und der link zum Programm-Download von Root Genius. Die Treiber und der Flashtool-Zubehör gibts im Wiki - SHIFT7-FAQ - unter StockROM.

Hier mehr dazu: was es mit dem StockROM auf sich hat und "Stockrom aufspielen".
 

flyingman

New member
Jul 14, 2015
3
Hallo zusammen,
flaschen mit incl. Speicheraufteilung hat bei mir soeben problemlos geklappt.

Das Stockrom welches man im Wiki runterladen kann hat aber ein anderes Datum (GP305_C1_SHIFT7_V1.03_20150112), den 12.01.2015 - und nicht wie im Video den 13.01.2015. Wie war das bei Euch und was sagt der Support dazu!?

Außerdem fehlt mir nach dem flaschen oben in der Statuszeile die Akkuanzeige in Prozent(die hatte ich seit meinem Austausch-Shift - ich meine Version 1.04)
 

detlefr

SHIFT Friend
Feb 6, 2015
3,155
Die Akkuanzeige musst du aktivieren, schau die die Einstellungsvideos an. In Einstellungen Akku kannst du bei Akkuprozent ein Häkchen setzen, dann wird das wieder angezeigt.
Zu den Softwareversionen, die vom 13.1.2015 ist noch nicht hochgespielt worden, der der das macht ist wohl krank, und ich habe keine Berechtigung dafür. Hierhin schicken geht nicht, da die Datei zu groß ist. Es geht aber auch mit der Version, die du genommen hast. Ich kenne auch nicht die detaillierten Unterschiede.
 

dirkw

Active member
Feb 8, 2015
184
Ich hatte auch die Version 20150112 verwendet - es geht definitiv damit.

Das mit der neuen Speicherverwaltung ist schon cool - hatte ich vorher (mit dieser komischen Aufteilung) nur 223 MB frei, so sind es jetzt knapp 5 GB. ;) So viel kann ich gar nicht installieren, damit ich den Speicher jetzt voll bekomme. :D
 

Weon

Member
Mar 18, 2015
26
Gerät(e) / Device(s)
SHIFT7+
Wo finde ich denn die modifizierte Rom? Oder hab ich hier was total überlesen?
 

detlefr

SHIFT Friend
Feb 6, 2015
3,155
Die ist noch nicht im Wiki, kommt aber noch. Hier kann ich sie nicht hinpacken, da sie zu groß ist.
 

dirkw

Active member
Feb 8, 2015
184
@Heike Wi: Ach ja, zu deinem Erfahrungsbericht wollt ich noch zum Punkt 6 Stellung nehmen.

Bei mir kommt auch seit dem Rooten nach dem Start des Shift7 die Meldung, "Damaged USB-Speicher ist beschädigt" und wenn man draufklickt die Frage "Die SD-Karte ist vielleicht beschädigt - wollen sie sie formatieren oder abbrechen?"

Ich ignoriere das, weil die SD-Karte (ich nimm mal an, die ist mit USB-Speicher gemeint) vorher nicht defekt war, und nachdem sich seit dem Rooten nichts geändert hat, kann die gar nicht defekt sein.

Es funktioniert jedenfalls alles, was auf der SD-Karte gespeichert ist.
 

HannsDieter

Well-known member
Feb 6, 2015
453
Ein ähnliches Problem ist bei uns bei Tests aufgetreten, insbesondere bei einer Vorgängervariante der angepassten Datei, bei der nur 4GB überschrieben wurden und 2GB weiterhin als unbenutzbare Partition "Phone Storage" vorhanden waren. Auf den englischen Geräten hieß es allerdings "Damaged Phone Storage".

Den konnte man formatieren oder nicht. Einen Unterschied hat es nicht gemacht, da der Bereich ohnehin leer war. Die Meldung tauchte bei jedem Neustart des Geräts auf.

Hier kann es also entweder sein, dass ebenfalls ein Rest des Phone Storage gemeint ist (und die Übersetzung ins deutsche, wie so oft, etwas holprig ist) oder tatsächlich die SD Karte gemeint ist. Taucht die Meldung auch auf, wenn ihr die SD Karte entfernt und neu startet? Wie ist es mit anderen SD Karten? Man könnte den Inhalt der SD Karte auch mal auf den PC ziehen (Backup) und dann über das SHIFT formatieren anklicken und gucken was passiert...
 

detlefr

SHIFT Friend
Feb 6, 2015
3,155
Der tüdelt da rum. Die SDKarte wird ganz normal angesprochen, nur bei der Meldung ist das irgendwie wohl verrutscht. Du musst die Meldung einfach ignorieren. Das, was früher der usb Speicher war, der ist eigentlich verschwunden, naja, er ist dem internen Speicher zugeordnet. Also nicht verrückt machen lassen, das ist halt die EDV :?
 

Weon

Member
Mar 18, 2015
26
Gerät(e) / Device(s)
SHIFT7+
Kann mir vielleicht jemand die mod. Rom zukommen lassen? Oder irgendwo hochladen?
 

IMR

Member
Feb 7, 2015
22
Ich hab vor drei Tagen das Shift7 geflasht ohne zu Rooten. hat soweit alles geklappt auch ohne große Schwierigkeiten. Werde aber es wohl wieder rückgängig machen da sich das Shift7 wie vor dem Update jetzt immer wieder aufhängt und neu gestartet werden muss.
Das macht so keinen Sinn da ich es nicht mitkriege wenn es abschaltet bzw. sich aufhängt.

Dann lieber mit kleinerem Speicher aber zuverlässig.
 

detlefr

SHIFT Friend
Feb 6, 2015
3,155
Das ist wohl in der version 1.3 vom 13.1.2015 nicht der Fall, da ich solch ein Verhalten nie gehabt habe. Die Software soll ins Wiki, ist aber leider noch nichtda, da derjenige, der dazu berechtigt ist, es noch nicht geschafft hat.
Ich weiss im Moment auch nicht, wo ich sie sonst hochladen sollte. Per email geht auch nicht, da die Datei zu groß ist.
 

dirkw

Active member
Feb 8, 2015
184
@IMR: Verstehe ich richtig, dass du nur die Speicherverwaltung geändert hast? Wenn ja, würd ich nochmals das komplette Programm (mit Rooten) durchführen (so wie in den Videos von Detlef), weil ich keine Abstürze habe. Vielleicht braucht die geänderte Speicherverwaltung root?
 

HannsDieter

Well-known member
Feb 6, 2015
453
IMR said:
Ich hab vor drei Tagen das Shift7 geflasht ohne zu Rooten. hat soweit alles geklappt auch ohne große Schwierigkeiten. Werde aber es wohl wieder rückgängig machen da sich das Shift7 wie vor dem Update jetzt immer wieder aufhängt und neu gestartet werden muss.
Das macht so keinen Sinn da ich es nicht mitkriege wenn es abschaltet bzw. sich aufhängt.

Dann lieber mit kleinerem Speicher aber zuverlässig.
Die Speicheränderung kannst du auch in der neuen Softwareversion durchführen. Nur das rooten funktioniert dann nicht.
Also erst das OTA Update einspielen, damit dein Handy sich nicht entlädt und dann nur die Schritte für das flashen der ebr Dateien für die Speichererweiterung durchführen. Dann solltest du die neuere Softwareversion mit großem Speicher haben (aber kein root).
 

detlefr

SHIFT Friend
Feb 6, 2015
3,155
Das funktioniert natürlich auch. Ich kann leider nicht Immer an alle Möglichkeiten denken. Aber deswegen sind wir ja auch mehrere :roll:
 

IMR

Member
Feb 7, 2015
22
@ Hanns Dieter: ich werde das mal in der nächsten Zeit ausprobieren melde mich dann wieder. Danke für den Tipp.

Wie muss ich das Handhaben?
1. Shift in Auslieferungszustand zurückversetzen
2. OTA Update 1.4
3. flashen mit ebr wie von detlefr beschrieben
stimmt das so?
 

detlefr

SHIFT Friend
Feb 6, 2015
3,155
Ja, bzw. du brauchst bloß das OTA durchführen. Ich glaube sogar, dass die Speicheraufteilung bestehen bleibt, lediglich root geht verloren (hab es nur nicht mehr so genau in Erinnerung). Also erst mal nur OTA ausführen, und sehen was ist.
 

IMR

Member
Feb 7, 2015
22
Also ich habe gestern erst geflasht um die alte Speicheraufteilung wieder her zu stellen und das OTA Update drüber laufen lassen. Leider schmiert das Shift immer wieder ab heute 3 Mal, was natürlich wenig erbaulich ist. Allein 2 Mal als ich das Netzteil reingesteckt habe. EDV halt! Soweit so blöd. Ich verstehe nur nicht warum es vorher anstandslos gelaufen ist und das jetzt nach dem neu flashen mit alter Speicheraufteilung und OTA Update nicht mehr läuft. keine neuen Programme bzw. Apps die alten Daten. Irgendwie hieß es ja mal never change a running system. :|
 

detlefr

SHIFT Friend
Feb 6, 2015
3,155
Vielleicht ist da doch was an der Hardware. Unter schmiert ab, verstehst du es schaltet sich aus, richtig? Es tat dies, indem du das Ladeteil eingesteckt hast. Probiere doch mal ein anderes Ladeteil, und versuch mal, ob der Fehler Reproduzierbar ist. Es ist immer sehr schwierig solche Fehler einzugrenzen, man muss dabei Geduld haben. Sporadisch auftretende Fehler sind fast nie zu finden, erst wenn man sie reproduzieren kann hat man eine Chance.
 

IMR

Member
Feb 7, 2015
22
mit dem Ladeteil hat es offensichtlich nichts zu tun, da das shift häufig abstürzt wenn es den Bildschirm abschaltet bzw. einige Zeit danach in einer Schleife (sichtbar an der Akkunutzung und Erwärmung) fest hängt. also ganz die Sache die eigentlich mit dem 1.4 Update bei mir behoben war.
 

detlefr

SHIFT Friend
Feb 6, 2015
3,155
Verändere doch mal die Abschaltzeiten, oder schalte selber ab. Ich habe diesen Fehler nie gehabt, deswegen denke ich, dass es noch eine andere Ursache haben muss
 

Weon

Member
Mar 18, 2015
26
Gerät(e) / Device(s)
SHIFT7+
gibt es einen Termin, wann das Stockrom ins wiki kommt?
 

dirkw

Active member
Feb 8, 2015
184
3 Wochen nach dem Flashen und Rooten sowie der Änderung der Speicherverwaltung funktioniert das Shift7 nach wie vor super - so wie ich es mir eigentlich von Februar an immer gewünscht hab. Seit ich massig freien Speicher habe und nicht mehr auf jedes Megabyte achten muss, nutz ich das Shift7 viel häufiger als vor dem Rooten.

Die (falsche) Meldung, dass die SD-Karte defekt sein, kommt nach wie vor bei jedem Start - ich ignoriere sie einfach.

Ich kann nur jedem raten, das rooten, flashen und Ändern der Speicherverwaltung durchzuführen.
 

detlefr

SHIFT Friend
Feb 6, 2015
3,155
@dirkw
Danke für das Feedback, Erfahrungen über einen längeren Zeitraum sind ganz wichtig, um noch Fehler aufzudecken. Also ruhig noch weitere Feedbacks (naja, nicht jeden Tag :roll: , das wäre dann auch wieder übertrieben, aber ich glaube du weisst schon was ich meine).


Die Software ist jetzt auch im Wiki
http://de.shiftphones.com/wiki/SHIFT7/FAQ/StockROM
 

IMR

Member
Feb 7, 2015
22
Hallo Zusammen,

zuerst hatte ich mit der Version vom 12.1.2015 das Shift7 geflasht und hatte Probleme die nach einigen Versuchen immer zu Abstürzen in Zusammenhang mit WLan (Laden oder automatischer Ruhestand) zu tun hatten.

Vor 2 Tagen habe ich mit der Version vom 13.1.2015 das Shift7 geflasht. Seit dem läuft bisher alles rund. Keine Abstürze oder Schwierigkeiten mehr. Ich werde es weiter beobachten.

Vielen Dank für eure Bemühungen vor allem an detlefr für die Videos und das viele Probieren.

IMR
 

detlefr

SHIFT Friend
Feb 6, 2015
3,155
@imr
wie sagt man so schön, dafür nicht. Aber ich freue mich, wenn es dann geklappt hat.
Es scheinen also wohl Unterschiede zwischen den beiden Versionen zu geben. Wir haben leider auch keine Detailinformationen darüber. Das ist auch ein Grund, warum Carsten die Softwarefirma geändert hat.
 
Status
Not open for further replies.