Webview Issues

VikTheKick

Original poster
Alpha Tester
Beta Tester
21 Oktober 2020
21
Hey Freunde,

Hab folgendes Problem.
Mir ist aufgefallen, dass die Akkuleistung extrem abgenommen hat, nachdem ich webview über den Aurora store upgedatet hatte. Ich bin mir aber nicht sicher, ob das tatsächlich die Ursache dafür ist. Dann kam ein neues Update, dass sich aber mit dem vermerkt "INSTALL_FAILED_MISSING_SHARED_LIBRARY" nicht installieren ließ. Screenshot im Anhang.
Ich hatte eine 87er webview Version drauf und wollte auf eine 90er updaten.

Ich habs dann mit einer Deinstallation mit anschließender Reinstallation versucht, mit dem selben Ergebnis.
Dann habe ich herausgefunden, dass es schon eine von Shift vorinstallierte neue Version gibt und ging davon aus, dass sie ausreichend sei. Dem ist wohl aber nicht so, da mindestens eine App ohne einer zusätzlichen webview installation nicht startet. 😅

Meine Fragen jetzt

- reicht die von shift vorinstallierte Version vllt doch und ich habe einfach nur etwas falsch gemacht beim Start der App?
- falls ich doch noch eine zusätzliche webview Installation brauche. Welche Version sollte ich nehmen und vor allem woher? Brauch ich dann auch die trichromelibrary?

Wäre super, wenn ihr da einen oder mehrere Tipps hättet. Achja, hab die neueste OS-L Version.

Lg, Vik
 

Anhänge

  • Screenshot_20210518-015858_Aurora_Store.png
    Screenshot_20210518-015858_Aurora_Store.png
    357,7 KB · Aufrufe: 15

amartinz

ShiftOS Developer
ShiftOS Developer
SHIFT Staff
19 März 2018
915
26
Wolfsberg, Austria
Die sollte die SHIFT WebView 90.0.4430.74 integriert haben.
Falls du andere WebViews hast, kannst du diese deinstallieren.

In Einstellungen -> System -> Erweitert -> Entwickleroptionen -> WebView

kannst du die WebView, welche verwendet werden soll, auswählen.
 

VikTheKick

Original poster
Alpha Tester
Beta Tester
21 Oktober 2020
21
Die sollte die SHIFT WebView 90.0.4430.74 integriert haben.
Falls du andere WebViews hast, kannst du diese deinstallieren.

In Einstellungen -> System -> Erweitert -> Entwickleroptionen -> WebView

kannst du die WebView, welche verwendet werden soll, auswählen.
Das habe ich schon versucht. Mit dem selben Ergebnis. OkCupid sagt mir immer noch, dass webview fehlt. Screenshots im Anhang.

Ich nutze microG, falls das relevant sein sollte.
 

Anhänge

  • Screenshot_20210519-091805_OkCupid.png
    Screenshot_20210519-091805_OkCupid.png
    71 KB · Aufrufe: 10
  • Screenshot_20210519-092308_Einstellungen.png
    Screenshot_20210519-092308_Einstellungen.png
    50,7 KB · Aufrufe: 10

danielp

SHIFT Friend
Alpha Tester
22 September 2019
1.885
Hab die App mal installiert und konnte das reproduzieren. Habe ein ähnliches Setup.
 

VikTheKick

Original poster
Alpha Tester
Beta Tester
21 Oktober 2020
21
Wie schon gesagt, wenn ich ein weiteres webview installiere, läuft die App ja. 🤷🏼
 

VikTheKick

Original poster
Alpha Tester
Beta Tester
21 Oktober 2020
21
Und bevor ich diese App nimmer nutze kann, könnte ich ja parallel eine andere webview Version installieren. Würde etwas dagegen sprechen?

Hab die aktuellste Version von apkmirror runtergeladen mit dazugehörigem trichromelibrary apk.