IPv6-Addressen von DNS-Server (Windows 10 Mobile Hotspot) werden nicht erkannt

PhoneFritz

Member
Original poster
25 März 2021
10
Hallo, folgendes Szenario:

Um Datenvolumen zu sparen, will ich mit meinem Shift 6mq das Festnetz-Internet meines Laptops mit benutzen. Also mache ich auf meinem Laptop unter Windows 10 einen "Mobile Hotspot" auf, zu dem ich mich dann mit meinem Shift 6mq verbinde. Also der Hotspot läuft auf dem Laptop, mit dessen SSID sich das Phone wie mit einem normalen WLAN verbindet.

Ich stelle allerdings fest, dass es dabei Internetprobleme auf dem Phone gibt. Vor allem im Browser (Chrome) werden keine Internetseiten geöffnet. Es kommen Fehlermeldungen, dass die IPs nicht gefunden werden; deutet also auf DNS-Probleme hin. Andere Apps (z.B. die Youtube-App) funktionieren hingegen und können Daten runterladen.

Mit einem anderen Windows 10 Laptop kann ich mich ohne Probleme mit dem Hotspot verbinden und surfen.
Wenn ich auf meinem Laptop Ubuntu boote und dort einen Hotspot aufmache, gibt es auf dem Phone keine Probleme mit dem Surfen.

Es scheint mir also an der Kombination "Windows 10 Hotspot <-> Shift 6mq" zu liegen.

Mein Laptop hat die "Intel® Wi-Fi 6E AX210" WLAN-Karte. Bei dieser ist die "klassische Variante" eines "Hosted Networks" anscheinend nicht mehr erlaubt (https://www.intel.com/content/www/us/en/support/articles/000023257/wireless.html), weswegen Windows 10 den Hotspot über "Wi-Fi Direct" realisiert. Ich kann das insofern bestätigen, dass in Windows ein neuer "Microsoft Wi-Fi Direct Virtual Adapter" von ipconfig /all angezeigt wird, sobald ich den Hotspot aufmache. Vielleicht hat das damit zu tun? Wird hier etwas vom Shift 6mq nicht unterstützt?

Danke und Grüße!
 

danielp

SHIFT Friend
Alpha Tester
Alpha Tester
22 September 2019
2.994
Doofe Frage wieso verbindest du das Telefon nicht direkt über WLAN?
Telefon -> Laptop -> WLAN kommt mir ein wenig umständlich vor!?

Das die Kombination Windows Windows funktioniert ist zu hoffen :)
Wenn aber Ubuntu mit Shift6mq funktioniert und Windows mit Shift6mq nicht würde ich es fast eher auf Windows schieben. :)
 

Klajo

Alpha Tester
Beta Tester
19 Juni 2019
69
Du kannst ja auf jeden Fall testen, ob es mit einem anderen DNS Server funktioniert.
(Bearbeite die Einstellungen deines WLAN und trage unter DNS 1 z.B. 1.1.1.1 ein)
 
  • Like
Reaktionen: danielp

PhoneFritz

Member
Original poster
25 März 2021
10
Bearbeite die Einstellungen deines WLAN und trage unter DNS 1 z.B. 1.1.1.1 ein
Danke, aber wo soll ich das einstellen? Wenn ich im Shift-OS in die Einstellungen der WLAN-Verbindung gehe, ist da bei DNS 192.168.137.1 angezeigt. Aber es ist ausgegraut und nicht editierbar. Wenn ich auf das Stift-Icon oben rechts klicke, kann ich lediglich "Metered", "Proxy", "DHCP" und "Use device MAC" einstellen...
 

Martin S.

SHIFT Friend
Alpha Tester
15 Februar 2020
1.134
Klick mal beim anlegen einer neuen Verbindung auf DHCP, dann kannst du verschiedene Sachen festlegen 🙂
 

Klajo

Alpha Tester
Beta Tester
19 Juni 2019
69
Genau andersrum, wenn du beim Stift Icon von DHCP auf Statisch umstellst, kannst du die DNS Server eintippen
 

PhoneFritz

Member
Original poster
25 März 2021
10
Hey, cool. Auf Eure Ratschläge hin habe ich mal bei den IP-Einstellungen des von mir im ersten Post erwähnten "Microsoft Wi-Fi Direct Virtual Adapter" geschaut. Und da sind als DNS-Server nur IPv6 Adressen angegeben:

1647976029499.png

Anscheinend macht der Windows Mobile Hotspot das so per Default.
Damit scheint das Shift-OS nichts anfangen zu können.

Nachdem ich jetzt hingegangen bin und IPv4 Adressen angegben habe, funzt es!

1647976131176.png
 

danielp

SHIFT Friend
Alpha Tester
Alpha Tester
22 September 2019
2.994
Danke, aber wo soll ich das einstellen?
Wollte gerade schreiben das die DNS Einstellungen des Hotspots geändert werden müssen.

Anscheinend verwendet Ubuntu noch IPv4 und Windows IPv6.

Meine mich zu erinnern das schon mal Probleme mit IPv6 berichtet wurden. Das war aber glaube ich in einem anderen Zusammenhang.
 
  • Like
Reaktionen: PhoneFritz

PhoneFritz

Member
Original poster
25 März 2021
10
Ich habe den Titel dieses Threads mal entsprechend angepasst. Vielleicht will sich das ein Dev ja mal genauer anschauen.
 
  • Like
Reaktionen: danielp

@Lhotze

Alpha Tester
Beta Tester
21 Oktober 2020
500
Hört sich, wie Daniel schon vermutet hat wirklich wie ein Problem an, bei dem Windows seinen Teil zu beiträgt. Hast du mal (nur zum Testen) versucht die DNS in Win10 direkt zu ändern? So dass Windows und das 6mq dann über die Windows-DNS ins Netz gehen? Anleitung (hier zum Bsp für Cloudflare) gibt's hier.
Hier noch ne Anleitung um IPV6 bei Win10 zu deaktivieren. It's worth a try 🤷🏼‍♂️.
Greetz
 

PhoneFritz

Member
Original poster
25 März 2021
10
Hört sich, wie Daniel schon vermutet hat wirklich wie ein Problem an, bei dem Windows seinen Teil zu beiträgt. Hast du mal (nur zum Testen) versucht die DNS in Win10 direkt zu ändern? So dass Windows und das 6mq dann über die Windows-DNS ins Netz gehen? Anleitung (hier zum Bsp für Cloudflare) gibt's hier.
Hier noch ne Anleitung um IPV6 bei Win10 zu deaktivieren. It's worth a try 🤷🏼‍♂️.
Greetz
Es läuft ja jetzt, nachdem ich beim Windows Mobile Hotspot für die DNS-Server IPv4-Adressen angegeben habe. Per Default gibt Windows da anscheinend nur noch IPv6 Adressen an, mit denen das Shift-OS irgendein Problem zu haben scheint. Da kann man jetzt sagen "das ist die Schuld von Windows", oder es so machen, dass das Shift-OS auch mit IPv6 zurecht kommt.
 
  • Like
Reaktionen: Choreas

danielp

SHIFT Friend
Alpha Tester
Alpha Tester
22 September 2019
2.994
Ich würde auch meinen das da irgendetwas mit der IPv6 Unterstützung beim 6mq nicht richtig läuft. @amartinz habt ihr das auf dem Schirm? IPv6 war ja schon ein paar Mal Thema.
 
  • Like
Reaktionen: PhoneFritz