ADB im Recovery: Keine Berechtigung

kinoe

Beta Tester
Sep 10, 2019
12
Gerät(e) / Device(s)
SHIFT6m
ein Hallo an alle, denen was dazu einfällt, dass mein Shift6m im normal laufenden System mit ADB folgendes auswirft:
ADBauthorized.PNG
es ist demnach autorisiert und ich kann weitere Befehle umsetzen.

Wenn ich aber im RECOVERY Modus das gleiche mache ist es NICHT autorisiert:
ADBunauthorized.PNG

Ursprünglich wollte ich die Systemschriftart ändern (thread hier), kam dann aber wegen diesem Thema nicht weiter.
Trotz unzähliger Tipps, Ansätze und Versuche klappt es nicht, egal ob von Linux oder Windows aus!

@developers: ist das so konfiguriert? Kann ich es irgendwie ändern? Oder ist das ein bug?

Zur Behebung habe ich folgendes versucht:

am Phone:
- USB-Debugging-Autorisierung deaktiviert
-die USB-Debugging-Berechtigungen aufgehoben

am PC (Windows 7):
-adb kill-server
-gelöscht: C: Benutzer/$Name/android/adbkey.pub & C: Benutzer/$Name/.android/adbkey
-adb start-server

am Phone:
-USB-Debugging-Autorisierung aktiviert
-an den PC angeschlossen
-Autorisierung in der Meldung 'USB-Debugging-Zugriff zulassen? ...'

am PC:
-adb devices (gut="device"=autorisiert)

am Phone:
-in den Recoverymodus gebootet
am PC:
-adb devices (fehlgeschlagen=unauthorized)
 
Last edited:
  • Like
Reactions: Felix B

kinoe

Beta Tester
Sep 10, 2019
12
Gerät(e) / Device(s)
SHIFT6m
Ich verwende ShiftOS-G also die Google-Version, keine Beta-Version, außerdem benutze ich Xposed-Framework version 90-beta3
amartinz sagt hier:
Ich nehme an du hast eine Beta version installiert?
Die sind nämlich "userdebug" und haben eine "su" binary für ADB.
Das heißt für mich: in der Beta-Version gibt es eine su für adb aber in der Standard-Version gibt es keine su für adb !??
@amartinz ist das richtig?

Oder unterstützt das android stock recovery schlicht adb nicht?

Edit: Unter
Einstellungen> System> Entwickleroptionen> MTK Entwicklerwerkzeuge> Reiter"Log and Debugging"> Debug Utils> Debug Level
kann man zwischen 'UserMode' und 'Engineer Mode' wählen
allerdings sagt mir das System dann Change Debug Level [CustomerUser-> CustomerEngineer] too frequent, please retry later
Eine Änderung ist so scheinbar nicht möglich!😤
Was will mir das sagen "Debug Level ändern zu häufig, versuche es später nochmal"????
 
Last edited:
  • Like
Reactions: Felix B

Felix B

Beta Tester
Sep 16, 2019
13
Gerät(e) / Device(s)
SHIFT6m
Habe zwar ein anderes setup und Ziel, aber ich glaube unser Problem ist das gleiche. [habe btw ein Shift6m]

1) Konntest du das xposed framework denn installieren ? also nicht nur die "app" sondern auch innerhalb der app das "framework version 90-beta3 "? das geht bei mir nämlich schon nicht. genau wie busybox einfach nicht auf /system kommt mit rw. Trotz verifiziertem root und Versuchen mit zig Anleitungen über adb shell, root file explorer, aufheben der SELinuxPolicies und was weiß ich /system auf rw gemountet zu bekommen.
2) habe jetzt eine BETA installiert (diese hier: ShiftOS-L ) weil ich auch den post von @amartinz gesehen hatte. Hilft aber nichts, ist trotzdem eine uservariant=user statt userdebug. oder ich bin zu blöd entsprechend auf das entsprechende Debug Level zu wechseln.
3) bei der von dir genannten Einstellung zu Debug Level war ich zwischenzeitlich auch, bekomme aber die gleiche Rückmeldung wie du.

Wüsste gern ob es überhaupt möglich ist mit den von Shift bereitgestellten OS zu erreichen was wir vorhaben und es nur an mir liegt. ;)
Falls jemand mit einer kurzen Anleitung oder dem entscheidenden Rädchen weiterhelfen kann wäre ich sehr dankbar.
 

kinoe

Beta Tester
Sep 10, 2019
12
Gerät(e) / Device(s)
SHIFT6m
Hi Felix ja /system scheint bei mir rw gemountet zu sein, denn die Installation des Xposed framework ist völlig normal über die Bühne gegangen.
Keine Idee was da bei deinem Gerät abläuft:confused:
Ja ich habe auch den Eindruck dass ShiftOS da grundsätzlich eine Art Sperre hat ist eben nur die Frage ob/wie man die beseitigen kann.
Habe zu dem Thema amartinz direkt angefragt mal schauen ob eine Antwort kommt...
Hast du ein custom recovery a lá TWRP? Vielleicht ließe sich damit was herausfinden bzw sogar stemmen
Hast du Erfahrung mit Lineage? Ich denke umzusteigen, weil ich es mir benutzerfreundlicher vorstelle. Scheue aber vor den Bugs zurück (zB dass man mal nicht anrufbar sein soll u.ä.)
 
Last edited:

Felix B

Beta Tester
Sep 16, 2019
13
Gerät(e) / Device(s)
SHIFT6m
Hi Felix ja /system scheint bei mir rw gemountet zu sein, denn die Installation des Xposed framework ist völlig normal über die Bühne gegangen.
Keine Idee was da bei deinem Gerät abläuft:confused:
Ja ich habe auch den Eindruck dass ShiftOS da grundsätzlich eine Art Sperre hat ist eben nur die Frage ob/wie man die beseitigen kann.
Hattest du außer den von dir hier beschriebenen Schritten noch etwas gemacht? u.a. diese Befehle habe ich natürlich auch versucht ;)

Habe zu dem Thema amartinz direkt angefragt mal schauen ob eine Antwort kommt...
Das wär natürlich super, würde das 6m gern als Haupthandy ins Rennen schicken, aber alles zu übertragen wenn ich ggf nochmal resetten muss will ich auch nicht ...

Hast du ein custom recovery a lá TWRP? Vielleicht ließe sich damit was herausfinden bzw sogar stemmen
Gibt es denn für das 6m ein verwendbares? Hab hier aus dem Forum rausgelesen, dass TWRP in Arbeit aber noch nichts released.
Sonst würde ich das natürlich gern versuchen.

Hast du Erfahrung mit Lineage? Ich denke umzusteigen, weil ich es mir benutzerfreundlicher vorstelle. Scheue aber vor den Bugs zurück (zB dass man mal nicht anrufbar sein soll u.ä.)
Habe auf meinem derzeitigen (OnePlus X (onyx) ) den Vorgänger CyanogenMod 13 (Android 6.0.1) laufen seit 2016 - außer einer kleinen Fehlermeldung (die aber nichts beinflusst) nach reboot läuft alles einwandfrei und ich bin sehr glücklich damit gewesen bis dato. Aber der Thread hier im Forum bei Third Party OS zu Lineage schreckt mich auch ein wenig ab, inbesondere die Ausfälle beim Empfang. Sonst wäre ich glaube ich gleich umgestiegen :)
 

kinoe

Beta Tester
Sep 10, 2019
12
Gerät(e) / Device(s)
SHIFT6m
Du meinst wahrscheinlich die ganzen adb-Befehle, richtig? Nö das ist es ja: Ich kann mich nicht erinnern noch andere außergewöhnliche Schritte unternommen zu haben.
Kannst du ausschließen, dass du nicht irgendetwas installiert, gemodded oder deinstalliert hast, das dann evt. zur Folge hatte, dass du keinen rw-Zugriff als root aufs system hast?
Du hast ja schon versucht mit nem root Dateimanager irgendwas im system zu ändern. Ich kann mit root essentials Dateien in /system verändern, hat also rw-Zugriff. Weiter wüsste ich erstmal auch nicht...🤷‍♂️

Das verlinkte TWRP von raymanfx müsste laufen, denn soweit ich weiß ist es Voraussetzung zur Installation von Lineage.
Werde es die Tage versuchen zu flashen. Mal sehen. Ich könnts gebrauchen auch für die system fonts. Lineage kommt sehr wahrscheinlich bald auf die Kiste bei mir. Vielleicht warte ich noch bis es das nächste Update und dann als .zip gibt.
Denn ich habe gerade die Nase voll für meine Bequemlichkeit, die mir all dieses Gegoogle gibt, mit einer astreinen Wanze zu leben, nach der sich die Stasi die Finger geleckt hätte😉 früher mussten die noch heimlich ins Haus kommen, heute gibt man selber horrende Summen aus, um sich dann ungefragt durchleuchten zu lassen und mit einem "verkrüppelten" OS noch nicht mal grundlegend was daran ändern zu können.🤬
 
Last edited:

Felix B

Beta Tester
Sep 16, 2019
13
Gerät(e) / Device(s)
SHIFT6m
Du meinst wahrscheinlich die ganzen adb-Befehle, richtig? Nö das ist es ja: Ich kann mich nicht erinnern noch andere außergewöhnliche Schritte unternommen zu haben.
Kannst du ausschließen, dass du nicht irgendetwas installiert, gemodded oder deinstalliert hast, das dann evt. zur Folge hatte, dass du keinen rw-Zugriff als root aufs system hast?
Du hast ja schon versucht mit nem root Dateimanager irgendwas im system zu ändern. Ich kann mit root essentials Dateien in /system verändern, hat also rw-Zugriff. Weiter wüsste ich erstmal auch nicht...🤷‍♂️
Genau meinte die entsprechenden adb commands. Ich hatte basierend auf dem ShiftOS-G das vorinstalliert war alles möglich versucht und habe irgendwann aufgegeben und dachte vielleicht komme ich mit Werksreset und dann ShiftOS-L und von vorn weiter. Dann nur magisk manager drauf, *img gepatcht, über MTKtool geflasht und über magisk root geholt, als nächstes direkt xposed und busybox drauf, die jeweils versucht zu installieren. geht aber nicht, er meldet zwar "mounting /system rw ..." noch ohne Fehler, aber alle Schritte danach quitiert er nur mit "fail". Und über adb shell > su > whoami (=root - das funktioniert also) > mount (=/system ro) > mount –o remount,rw /system (=kein Fehler) bekomme ich /system weiterhin partout nicht rw mounted.
root essentials hatte ich noch nicht probiert, aber wie hier beschrieben schon zwei andere tools.


Das verlinkte TWRP von raymanfx müsste laufen, denn soweit ich weiß ist es Voraussetzung zur Installation von Lineage.
Werde es die Tage versuchen zu flashen. Mal sehen. Ich könnts gebrauchen auch für die system fonts. Lineage kommt sehr wahrscheinlich bald auf die Kiste bei mir. Vielleicht warte ich noch bis es das nächste Update und dann als .zip gibt.
Vielleicht die beste Idee ;)

Denn ich habe gerade die Nase voll für meine Bequemlichkeit, die mir all dieses Gegoogle gibt, mit einer astreinen Wanze zu leben, nach der sich die Stasi die Finger geleckt hätte😉 früher mussten die noch heimlich ins Haus kommen, heute gibt man selber horrende Summen aus, um sich dann ungefragt durchleuchten zu lassen und mit einem "verkrüppelten" OS noch nicht mal grundlegend was daran ändern zu können.🤬
🤪