SHIFT5me SHIFT6m Root Anleitung

jande

Beta Tester
May 5, 2019
8
Gerät(e) / Device(s)
Keines / None
Hallo,
ich habe für mein 5me die Datei SHIFT5ME.SOS.1.1.G.20190115 heruntergeladen und alles nach Anleitung durchgeführt. Trotzdem startet der Flashvorgang bei mir nicht. Fehlermeldung:

ERROR : STATUS_ERR (-1073676287) , MSP ERROE CODE : 0x00.
[HINT]:


Rooten.png

Die Änderungen unter Optionen habe ich vorgenommen ("Full Speed" und "with Battery").

Hat einer von Euch vielleicht nen Tipp?

Beste Grüße,

Jan
 

jande

Beta Tester
May 5, 2019
8
Gerät(e) / Device(s)
Keines / None
OK, ich nutze Linux und musste das FlashTool mit Root starten. Leider ist der Flashvorgang schiefgegangen und das Programm hat sich mit folgender Fehlermeldung beendet:

FlashvorgangFailed.png

Jetzt kann ich mein Handy nicht mehr starten (Der Shift-Ḱreisel läuft durch; danach passiert nichts mehr).

HIIILFE!

Jan, leicht panisch.
 

jande

Beta Tester
May 5, 2019
8
Gerät(e) / Device(s)
Keines / None
Die Panik hat sich gelegt. Ich habe die Windows-Version des FlashTools verwendet und konnte damit die magisk_patched.img aufspielen. Das Gerät startet wieder. :)

Allerdings steht im Magisk Manager unter Magisk immer noch "nicht installiert". Ich nehme also an, das Gerät ist nach wie vor nicht gerootet? Hat dafür einer von Euch ne Erklärung?

Herzliche Grüße,

Jan
 

flederwiesel

New member
Aug 7, 2019
4
Ludwigshafen, Germany
Gerät(e) / Device(s)
SHIFT5me
Hallo zusammen,
seit ca. 4 Wochen habe ich jetzt mein Shift 5me, kann es aber nicht wirklich benutzen, da noch immer nicht gerootet. Nachdem auf der shiftphone-Homepage sogar Anleitungen dafür exisitieren, habe ich mir das Teil hoffnungsfroh bestellt.

Nach genauerem Hinsehen ist es aber wohl auch hier so, dass dabei Software benutzt werden muss, wo nicht klar ist, aus welchen Quellen diese stammt - namentlich SP Flash Tool. Nach meinen Recheren gibt es wohl auch eine Open Source Version, allerdings scheint diese mit der unter spflashtools.com nicht identisch zu sein.

Da ich immer mehr persönliche Informationen auf dem Gerät speichere - bis hin zu 2FA und Online-Banking - habe ich ein Problem damit, Software aus nicht verifizierbaren Quellen zu benutzen - es gibt nicht einmal ein Impressum... - und hierin enthaltene *.bin-Dateien auf mein Gerät zu flashen.

Deshalb die Frage: Wie bekomme ich das Gerät nun gerootet, OHNE SP Flash Tool o.ä. zu benutzen, und anschließend sicher zu sein, dass wirklich nur das mit dem Gerät passiert, was ich beansichtige - root-Zugriff zu bekommen?

Ich fände es schade, wenn dies nicht Out-Of-The-Box möglich ist. So bekäme der Slogan "Smartphones can be timekillers" eine leider neue Bedeutung...

Paranoide Grüße,
Tobias aka flederwiesel
 

SH1FT

Member
Jul 17, 2019
17
Gerät(e) / Device(s)
SHIFT5me
Hallo,

ich hatte vor einiger Zeit dank dieser Anleitung ein Shift5me erfolgreich rooten können (wenn auch mit oben von jemand anderem beschriebener, verunsichernder Fehlermeldung). Das erfolgreich gerootete Shift5me war ein zugesendetes Ersatzgerät mit der Version SHIFT5ME.SOS.1.1.G.20190510.

Nachdem ich nun endlich ein schwerwiegendes Hardware-Problem (siehe dieser Thread) mit meinem eigenen Shift5me gelöst habe, wollte ich mich auch um dieses kümmern und es rooten. Das ist sehr wichtig für mich, da ich nur so ein komplettes BackUp erstellen kann.

Allerdings gab es zwischenzeitlich ja ein ShiftOS-Update, welches ich erfolgreich durchgeführt hatte (auf SHIFT5ME.SOS.1.1.G.20190823). Und dazu finde ich nun nicht mehr das passende Flashtool-Package... was tun? Ich meine in alle Bereiche bzw. Categories der Ressources reingeschaut zu haben... Kommt da zeitnah etwas nach? Oder kann ich das vorherige Flashtool-Package verwenden?

Ich hoffe, dass man mir hier helfen kann... - es macht mir etwas Sorge, dass die letzten Fragen oben vom August bisher unbeantwortet blieben.
VIELEN DANK!
 

SH1FT

Member
Jul 17, 2019
17
Gerät(e) / Device(s)
SHIFT5me
Super, vielen Dank.
Das rooten hat geklappt, allerdings gab es paar Probleme.
Es war (mal wieder) etwas kompliziert die entsprechenden Treiber in meinem Windows 7 x64 für das Shiftphone im PreLoader-Status zu haben - generell versuchte Windows des öfteren erfolglos das Gerät zu installieren und präsentierte in dem kleinen Dialogfenster für die automatische Treiberinstallation rote Xe statt der grünen Haken... hier ein Screenshot von einem der Versuche:
2019-09-13 01_01_24-Gerätetreiberinstallation.jpg

Allerdings bedeutet das, wie ich ja nun feststellte, nicht zwangsläufig, dass es nicht funktionieren wird. Bei einem erneuten Versuch nach einem Systemneustart erkannte das wartende SPTool, dass etwas angeschlossen wurde und erledigte seine Arbeit.

Achja - ich hatte außerdem leider zuerst auch noch versehentlich das Package SHIFT6M.SOS.1.1.G.20190823-FLASHTOOL.zip statt SHIFT5ME.SOS.1.1.G.20190823-FLASHTOOL.zip benutzt... Dabei kam es im SPTool zu folgender Fehlermeldung:
2019-09-13 01_03_29-Smart Phone Flash Tool.jpg
Dauerte etwas, bis ich hinter die Ursache kam, alles nochmal machte und dann am Ende Erfolg hatte.
 

SH1FT

Member
Jul 17, 2019
17
Gerät(e) / Device(s)
SHIFT5me
Lasst mir doch bitte einen kurzen Kommentar hier, sollte die Anleitung für euch funktioniert haben. Wenn nicht, weiß ich wo ich eventuell nachbessern kann.
Wurde in weiteren Beiträgen schon mal erwähnt und ich schließe mich an:
1. in Magisk muss man auf "Installieren" und dann im nächsten Fenster ebenfalls nochmal "Installieren" tippen, bevor man zu der ""boot-verified.img " navigieren und sie zum Patchen auswählen kann
2. die gepatchte Datei nennt sich "magisk_patched.img" statt "patched_boot.img".

Wäre super, wenn das in die Anleitung einfließen könnte. Nur dank dieses Threads hatte ich es geschafft zwei Shift5me zu rooten
Vielen Dank!
 

mot_the

Beta Tester
Feb 14, 2019
21
Gerät(e) / Device(s)
SHIFT5me
Wurde in weiteren Beiträgen schon mal erwähnt und ich schließe mich an:
1. in Magisk muss man auf "Installieren" und dann im nächsten Fenster ebenfalls nochmal "Installieren" tippen, bevor man zu der ""boot-verified.img " navigieren und sie zum Patchen auswählen kann
2. die gepatchte Datei nennt sich "magisk_patched.img" statt "patched_boot.img".

Wäre super, wenn das in die Anleitung einfließen könnte. Nur dank dieses Threads hatte ich es geschafft zwei Shift5me zu rooten
Vielen Dank!
Vielen Dank für den Hinweis, habe ich gerade ergänzt. :)
 
  • Like
Reactions: SH1FT

crabanus

Member
Sep 14, 2019
6
Gerät(e) / Device(s)
SHIFT6m
Halloechen, auch von meiner Seite Danke für die gute Anleitung. Bei mir funktioniert es nur leider nicht. :-(

Ich folge den Schritten exakt und bekomme auch keine Fehlermeldung. Ich nutze Magisk Manager Version 7.3.2, SP Flash Tool 5.1916.00 und ShiftOS SHIFT6M.SOS.1.1.G.20190823. Habe das boot-verified.img aus dem entsprechenden Flashtool-Zip zum Patchen verwendet (SHIFT6M.SOS.1.1.G.20190823-FLASHTOOL.zip) und dann aufs Telefon downgeloaded - das Flash-Tool quittiert das mit einem dicken grünen Haken. Nach dem Reboot ist aber Magisk immer noch nicht installiert und root funzt nicht (will das für Titanium Backup) - sieht also ähnlich aus wie bei Jande (s.o.).

Was mache ich falsch? Any hints? Danke!

Update (15.9.2019): Hab die Lösung gefunden. Das Problem war, dass ich vor dem Rooten bereits ein Update auf die aktuelle Version (build vom 23.8.2019) per Update-Funktion im Android gemacht habe. Dadurch wurde Slot B im Handy aktiv und mein Rooten von Slot A hat sich nicht gezeigt. Nach dem manuellen zurückdrehen des aktiven Slots mit fastboot --set-active 'a'' hatte ich das gerootete Environment. :)
 
Last edited:

SH1FT

Member
Jul 17, 2019
17
Gerät(e) / Device(s)
SHIFT5me
Nach dem Reboot ist aber Magisk immer noch nicht installiert und root funzt nicht (will das für Titanium Backup)

Update (15.9.2019): Hab die Lösung gefunden. Das Problem war, dass ich vor dem Rooten bereits ein Update auf die aktuelle Version (build vom 23.8.2019) per Update-Funktion im Android gemacht habe. Dadurch wurde Slot B im Handy aktiv und mein Rooten von Slot A hat sich nicht gezeigt. Nach dem manuellen zurückdrehen des aktiven Slots mit fastboot --set-active 'a'' hatte ich das gerootete Environment. :)
Hallo,
ich habe nun mein Shift 5me 464 bekommen und wollte es rooten. Habe also alles genauso gemacht wie zuvor (zuerst OTA Update auf neusten build, dann obige Anleitung befolgt - nat. mit dem richtigen Flashtool-Paket - bis am Ende eben das FlashTool einen großen grünen Haken mit "OK" anzeigte) und nach einem Neustart meint Magisk weiterhin nicht installiert zu sein... Sieht für mich also exakt nach dem zitierten Problem aus. Großartig, dass crabanus dann zwar eine Lösung fand - aber ich habe keine Ahnung, von was für "Slots" er da spricht und wie ich das "manuell zurückdrehen" kann :( Habe also mal nach dem Befehl gegoogelt und mir daraufhin das "Minimal ADB and Fastboot tool" als portable Version auf dem PC heruntergeladen. Und nun? War das überhaupt notwendig? Was muss ich tun, um das Problem genauso wie crabanus es getan hatte zu lösen?

BITTE UM ZEITNAHE UNTERSTÜTZUNG

SHIFT wartet aktuell auf die Retoure meines bisherigen Shift5me (332), aber davor muss ich erst das neue (464) rooten, Titanium Backup installieren und ein zuvor vom alten Phone gezogenes BackUp dort wiederherstellen...
DANKE
 

crabanus

Member
Sep 14, 2019
6
Gerät(e) / Device(s)
SHIFT6m
Hallo Sh1ft,

die beiden "Slots" auf dem Handy ermöglichen die Installation von zwei verschiedenen Boot-Environments. Anfangs bootet das Handy von Slot A, wenn Du ein neues OTA Update installierst, wird das in den nicht-aktiven Slot B installiert, dann wird der Slot nicht-aktive Slot B, in das das Update installiert wurde, aktiviert und Du bootest von Slot B. Das hat den Vorteil, dass im Falle, dass das Update fehlerhaft war, einfach wieder Slot A aktiviert werden kann und Du wieder ein lauffähiges System hast. Die Sache ist also so ähnlich wie bei einem PC mit zwei Boot-Platten - Du kannst jeweils (z.B. im BIOS) einstellen, von welcher Platte Du booten willst.

Wenn Du dann Magisk installierst, musst Du in den richtigen Slot installieren - also in den, von dem gebootet wird.

Ich habe das dann so gemacht, dass ich mit dem oben genannten fastboot-Kommando den aktiven Slot auf A nach dem OTA Update zurück gestellt habe - habe dann also die nicht aktualisierte Version gebootet. Dann habe ich entsrpechend der Anleitung unter https://topjohnwu.github.io/Magisk/tutorials.html#ota-installation erst das OTA Update und dann _vor dem Reboot_ Magisk in den inaktiven Slot (also in den Slot, in dem das OTA-Update sitzt) installiert. Nach einem Reboot war alles so wie erwünscht.

HTH und ciao...
 

SH1FT

Member
Jul 17, 2019
17
Gerät(e) / Device(s)
SHIFT5me
Danke!
Leider bin ich echt überfordert damit... habe keine Ahnung, was ich nun konkret an meinem Shiftphone machen muss, damit ich einfach endlich den neusten build inkl. root habe und mir das in dem Magisk angezeigt wird. Mit dem bisherigen Shift5me (332) hatzte ich es doch auch hinbekommen, ohne an irgendwelchen Slot-Geschichten rumfummeln zu müssen! :( Mein Shift5me (332) hat das neuste build und ist gerootet. Warum läuft das nun auf dem Shift5me 464 auf einmal anders...?

Also nochmal kurz der Status Quo bzw. Auflistung der von mir bereits durechgeführten Schritte mit dem zu rootenden Shift5me 464:
- neusten Build per OTA installiert
- Magisk installiert (d.h. neuste apk heruntergeladen, auf das Shift kopiert, installiert und nach dem Öffnen den Magisk Manager nochmal upgedatet, da es angeboten wurde).
- die zuvor aus dem richtigen Paket genommene boot-verified.img auf das Shiftphone kopiert
- im Magisk die boot-verified.img gepatcht und entstandene magisk_patched.img auf den Rechner kopiert
- Flashtool mit dieser scatterfile und der magisk_patched.img gefüttert, in Wartemodus versetzt, ausgeschaltetes Shiftphone angeschlossen und der Download wurde mit einem grünen Haken quittiert
- Shiftphone gestartet, Magisk geöffnet und festgestellt, dass Magisk nicht installiert ist (also der erste Eintrag.... für mich total verwirrend - wie kann es nicht installiert sein, wenn ich es doch gerade ausführe? "Magisk" ist offenbar nicht gleich "Magisk Manager"...? Mir qualmt der Kopf und ich bin nur noch im radikalen Akzeptanz-Modus ohne die ganzen Hintergründe zu schnallen)

Ich habe nun schon hilflos und inkompetent versucht alleine herauszufinden, was ich tun muss...:
- wie erwähnt das "Minimal ADB and Fastboot tool" als portable Version heruntergeladen, von den drei enthaltenen .exen gab es nur bei einer ("cmd-here.exe") mehr als nur ein superkurz aufgeblitztes Fenster...
- folgende Anleitung im zweiten Anlauf erfolgreich durchgespielt: https://forum.shiftphones.com/threads/rooten-shift-6m.1275/page-2#post-12398
Ergebnis:
Code:
C:\platform-tools>adb devices
List of devices attached
S5ME1196M000514 device
Auch das andere CMD-Fenster im Pfad des "Minimal ADB and Fastboot tool" ist noch offen


Ich hoffe davon war nichts kontaproduktiv... was genau schlägst Du vor muss ich nun tun?
Wo muss ich was eingeben, damit endlich der richtige Slot, mit dem richtigen build und root läuft?

DANKE!
 

crabanus

Member
Sep 14, 2019
6
Gerät(e) / Device(s)
SHIFT6m
Setz mal das Kommando adb shell "getprop | grep boot.slot" ab - dann bekommst Du angezeigt, aus welchem Slot Du gerade bootest. Eine adb-Verbindung scheinst Du ja zum Shiftphone zu haben (ggfs. mit adb connect erst verbinden).

Da ich das Shift5 nicht habe, kann ich Dir nicht sagen, ob es da die Technik mit den zwei Slots gibt - wie Du das beschreibst, wird es aber so sein. Nochmal: Die Slots sind wie zwei verschiedene Boot-Devices. Wenn Du von Platte 1 bootest und da 'was reininstallierst, dann aber einen Reboot von Platte 2 machst, wird Du das Installierte nicht sehen. Du musst erst wieder von Platte 1 booten. So ist es auch mit den Slots.

Hast Du Dir die Anleitung zum Magisk angeschaut? Da ist das eigentlich ganz gut erklärt. ;-) Und richtig: Der Magisk-Manager ist nicht dasselbe wie Magisk. Magisk ist der "root-Patch", der Magisk-Manager ist dazu da, diesen "root-Patch" zu installieren und zu verwalten. Wenn es ein Update gibt, wirst Du erst den Magisk-Manager aktualisieren. Der lädt dann den aktuellen "root-Patch" runter und installiert ihn - Du kannst auswählen, wo - ob im laufenden Image oder in den inaktiven Slot (was Du nach einem OTA Update machen musst - hast Du das gemacht?). Dann musst Du rebooten. Aber so weit bist Du noch nicht - Du scheinst noch den Magisk in den "falschen" Slot zu installieren.

Also, poste doch mal den Output von adb shell "getprop | grep boot.slot" und wirf noch mal einen Blick in das Tutorial zum Magisk.
 

SH1FT

Member
Jul 17, 2019
17
Gerät(e) / Device(s)
SHIFT5me
Zuerst: DANKE nochmal.

OK, eins nach dem anderen...:
Ich habe mal das cmd-Fenster vom "Minimal ADB and Fastboot tool" -Pfad genommen und den genannten Befehl eingegeben:
Code:
C:\minimal_adb_fastboot_1.4.3_portable>adb shell "getprop | grep boot.slot"
adb server version (41) doesn't match this client (39); killing...
* daemon started successfully
[ro.boot.slot_suffix]: [_b]
Ist das gut? Schlecht? Was kann ich damit anfangen?

Eine adb-Verbindung scheinst Du ja zum Shiftphone zu haben (ggfs. mit adb connect erst verbinden).
Habe ich eine? Woran erkennt man das?
Falls nicht: was heißt "mit adb connect erst verbinden"? Wo genau muss ich was eingeben?
Ich finde mich ja schon damit ab nicht zu wissen, was genau "adb" überhaupt ist, ich brauch einfach nur das nötigste um irgendwie zum gewünschten Ergebnis zu kommen. Windows zeigt ja auch bei jedem Anstecken irgendwelche Misserfolgsmeldungen bzgl. MTP & Co-Treiberinstallationen an (mit aktiviertem USB-Debugging wird das Shiftphone im Datei-Übertragungsmodus z.B. gar njicht angezeigt, ohne USB-Debugging schon) und dennoch hatte es bisher irgendwie mit den Verbindungen und rooten geklappt.
Bitte also wirklich wie für ganz Blöde erklären... zwar bin ich Fachinformatiker mit nun knapp 15 Jahren Beruferfahrung, aber IT ist eben nicht gleich IT... und hier kann ich leider kaum bis nix von meiner Erfahrung gebrauchen.

Danke für Deine sonntägliche Unterstützung!
 

SH1FT

Member
Jul 17, 2019
17
Gerät(e) / Device(s)
SHIFT5me
PS:
das mit den zwei Slots hatte ich verstanden, aber nicht genug, um daraus ableiten zu können, was explizit nun zu tun ist. Mein Shift5me 464 läuft ja nu mit dem aktuellen Build. UND der Magisk Manager ist drauf. Wenn ich da nun die Datei patche etc., dann habe ich entgegen des verlinkten Tutorials im Menü gar keine Möglichkeit in einen anderen Slot zu patchen. Es gab und gibt da immer nur zwei "Methoden":
"Nur Zip-Datei herunterladen" und
"Auswählen und Patchen einer Datei".
Ich hatte immer den zweiten Punkt genommen, die boot-verified.img gepatcht usw.

Das Tutorial zeigt dagegen einen Screenshot mit VIER Methoden...
 

crabanus

Member
Sep 14, 2019
6
Gerät(e) / Device(s)
SHIFT6m
Hallo Sh1ft,

also - Dein aktueller Boot-Slot ist wie vermutet Slot B ([ro.boot.slot_suffix]: [_b]). Das ist weder gut noch schlecht, das ist einfach so. "adb" steht übrigens für "Android Debug Bridge" - vgl. https://developer.android.com/studio/command-line/adb. Ich fand mich anfangs in genau der gleichen Situation (nach OTA Update war der aktuelle Slot der Slot B - und nach dem Reboot war mein Magisk immer wieder weg). Wenn es Dir nur darum geht, Dein Phone zu rooten um Titanium zu installieren, dann verzichte auf das OTA Update (wenn Deine Magisk-Version nicht die Möglichkeit bietet, in den inaktiven Slot zu installieren - bist Du sicher, dass Du die aktuelle Version nutzt?!?).

Für das Ändern des aktuellen Slots musst Du erst in den Bootloader mit folgendem Kommando booten: adb reboot bootloader

Im Bootloader kannst Du dann mit fastboot --set-active='a' den Slot A wieder aktiv machen. Dann bootest Du das alte Image (ACHTUNG: Ich weiss nicht, ob dann Deine Daten noch da sind - das müssten sie sein, ich habe aber kein Phone zur Hand, um das zu testen - vielleicht kann sonst jemand aus dem Forum hier helfen?!?). Dann kannst Du OHNE OTA Update den Magisk Manager installieren und das Image rooten, bzw. ich würde erwarten, dass das Image bereits gerootet ist (da ja Deine Installation vom Magisk erfolgreich war). Dann kannst Du Titanium installieren und backuppen.

Sollten Daten nicht mehr da sein, kann Du wieder in den Bootloaeder booten und dann den aktiven Slot mit fastboot wieder auf 'b' ändern. Ein Reboot sollte dann alles wieder zurück bringen. Aber ich kann das alles nicht garantieren, da ich es nicht testen kann.

Ich würde aber eigentlich eher vorschlagen, dass Du zusehen solltest, dass Du die Version von Magisk besorgst, die den inaktiven Slot zu flashen erlaubt. Welche Version vom Magisk hast Du denn? Meine Version war 7.3.2 - mit vier Installationsoptionen. Schau doch mal hier: https://magiskmanager.com/

Ich muss mich jetzt ausloggen - viel Glück!
 

SH1FT

Member
Jul 17, 2019
17
Gerät(e) / Device(s)
SHIFT5me
...nun ging mir genug Licht auf :D DANKE

Mein Magisk Manager wurde wirklich heute ganz neu von der Hersteller-Seite gezogen und installiert. Dies war die Version 7.3.5.
Wie beschrieben fand dann aber noch auf Nachfrage im laufenden Magisk Manager ein Update auf 7.4.0 statt und das bot nur zwei Methoden - keine Ahnung weshalb.

Um irgendwelche Daten musste ich mir übrigens keine Gedanken machen - das neue SHIFT5me 464 hatte noch nie irgendwelche Daten von mir drauf. Die soll es ja erst über eine Wiederherstellung des BackUps vom vorherigen SHIFT5me 332 bekommen. Aber dafür muss es eben erst auf dem neusten Stand & gerootet sein, sowie Titanium BackUp aufgespielt bekommen.

Nach Deiner Anleitung sah das dann also wie folgt bei mir aus:
Code:
C:\minimal_adb_fastboot_1.4.3_portable>adb shell "getprop | grep boot.slot"
adb server version (41) doesn't match this client (39); killing...
* daemon started successfully
[ro.boot.slot_suffix]: [_b]

C:\minimal_adb_fastboot_1.4.3_portable>adb reboot bootloader
adb server version (41) doesn't match this client (39); killing...
* daemon started successfully

C:\minimal_adb_fastboot_1.4.3_portable>fastboot --set-active='a'
Slot 'a' does not exist. supported slots are:
a
b

C:\minimal_adb_fastboot_1.4.3_portable>fastboot --set-active=a
Setting current slot to 'a'...
OKAY [  0.010s]
finished. total time: 0.011s
Was sollen eig. diese ständigen "adb server version (41) doesn't match this client (39); killing..."?

Wie auch immer, anschließend stand auf dem ansonsten schwarzen Handy-Display nur noch in Klein unten was von "fastboot enabled" (oder so) und es tat sich nix. War schon kurz davor den Akku rauszunehmen, da auch keiner der seitlichen Buttons was änderte, aber dann erinnerte ich mich irgendwo gelesen zu haben, dass man alle drei Knöpfe drücken müsste... Tat dies paar Sekunden lang und das Ding ging irgendwann aus.
Dann erneut eingeschaltet, es bootete und ich öffnete erwartungsvoll den "Magisk Manager".
Und nun war auch Magisk installiert! :D ENDLICH.

Ich prüfte dann mal die ShiftOS-Version und fand (natürlich... so langsam versteh ich das jetzt) wieder den vorherigen Build vor :cautious:
Also war ich noch immer nicht fertig.
Ich lud mir mal den neusten Build als zip-Datei runter (wenn ich im Nachhinein darüber nachdenke, war das wohl nicht nötig... aber geschadet wird es auch nicht haben) und startete anschließend - wie beschrieben - NICHT neu, sondern ging nochmal in den Magisk Manager. Dort hatte ich nun auf einmal vier Optionen und konnte den inaktiven Slot patchen. Es wunderte mich dabei schon, dass ich hier keine "boot-verified.img" zur Verfügung stellen musste.

Nach dem bestätigten Restart war dann:
1. das Gerät nach wie vor gerootet :giggle:(y)
2. der neuste Build drauf :giggle:(y)

DANKE!

Mein Gott, soviel Arbeit und Gehirnschmalz hatte ich noch nie für irgendein Smartphone investiert... o_O
 

SH1FT

Member
Jul 17, 2019
17
Gerät(e) / Device(s)
SHIFT5me
ja nu, aber dafür hätte ich es ja wieder an den PC anschließen müssen. Nachdem er "finished" geschrieben hatte, hatte ich es bereits abgezogen, da ich keinen Grund mehr für diesen adb-Zugriff sah.
Ich kümmere mich nun um das BackUp - hoffentlich klappt hier alles.
 

SH1FT

Member
Jul 17, 2019
17
Gerät(e) / Device(s)
SHIFT5me
Ich kümmere mich nun um das BackUp - hoffentlich klappt hier alles.
...wäre auch zu schön gewesen :cry:
Hab im Titanium BackUp des SHIFT5me 464 also mal die frische Komplettsicherung vom SHIFT5me 332 wiederherstellen wollen.

Bei jeder zu installierenden App musste ich jew. auf "Installieren" und danach "Fertig" klicken... :rolleyes: Automatisieren kann man das wohl nur in der Pro-Version. Doch leider gab es immer wieder mal Apps, die aus unbekannten Gründen nicht installiert werden konnten... und der Fortschrittsbalken blieb stehen. War nicht abbrechbar, Titanium BackUp "klemmte fest". Also musste ich jedes mal über die Einstellungen/Apps/ das Programm beenden, neustarten und dann die Komplettwiederherstellung erneut anstoßen - dann nat. immer mit den nun abgehakten Apps, die das Problem hatten. So schrieb ich mir im laufe der Zeit knapp 30 Apps auf, die sich schon mal nicht wiederherstellen ließen (z.B. Wikipedia). In einem Falle - bei dem Eintrag "System-UI" - kam sogar ein Reboot mit angezeigtem Fehler im Prebootloader. Über "Try again" konnte ich das SHIFT jedoch wieder starten und weiter machen.

Irgendwann jedoch kam es "richtig dicke" :cautious: Seit dem Versuch von Titanium Backup den Eintrag "Einstellungsspeicher" wiederherzustellen, rebootete das SHIFTphone... zeigte kurz den Sperrbildschirm und dann rebootete es erneut... und das immer und immer wieder. Ich konnte es nur durch Entnahme des Akkus stoppen. Nachdem ich ihn wieder eingesetzt und das Shiftphone gestartet habe: weiter das selbe Spiel.

Befinde mich nun also in einem Dauer-Rebootvorgang und das Gerät ist unbrauchbar. Was tun?
Wieso zur Hölle kann nicht einfach endlich mal was klappen und einfach alles vom alten Gerät wiederhergestellt werden? Ich dreh durch.
Das kann doch echt nicht so schwer sein!

Bitte erneut um Hilfe...
 

damigu

Beta Tester
Sep 4, 2019
1
Gerät(e) / Device(s)
SHIFT5me
Guten Abend zusammen

Gerne würde ich auf meinem 5Me auch Apps von Banken benutzen, doch leider wird der SafetyNet-Test in der Magisk-App nicht bestanden. Daher funktioniert Magisk-Hide nicht ordnungsgemäss und die Apps weigern sich zu starten.

Sowohl der ctsProfile- als auch der basicIntegrity-Test schlagen fehl. Kennt jemand eine Möglichkeit dies zu ändern?
Nutze die L-Version mit microG.

Liebe Grüsse Mirco
 

crabanus

Member
Sep 14, 2019
6
Gerät(e) / Device(s)
SHIFT6m
...wäre auch zu schön gewesen :cry:
Hab im Titanium BackUp des SHIFT5me 464 also mal die frische Komplettsicherung vom SHIFT5me 332 wiederherstellen wollen.

Bei jeder zu installierenden App musste ich jew. auf "Installieren" und danach "Fertig" klicken... :rolleyes: Automatisieren kann man das wohl nur in der Pro-Version. Doch leider gab es immer wieder mal Apps, die aus unbekannten Gründen nicht installiert werden konnten... und der Fortschrittsbalken blieb stehen. War nicht abbrechbar, Titanium BackUp "klemmte fest". Also musste ich jedes mal über die Einstellungen/Apps/ das Programm beenden, neustarten und dann die Komplettwiederherstellung erneut anstoßen - dann nat. immer mit den nun abgehakten Apps, die das Problem hatten. So schrieb ich mir im laufe der Zeit knapp 30 Apps auf, die sich schon mal nicht wiederherstellen ließen (z.B. Wikipedia). In einem Falle - bei dem Eintrag "System-UI" - kam sogar ein Reboot mit angezeigtem Fehler im Prebootloader. Über "Try again" konnte ich das SHIFT jedoch wieder starten und weiter machen.

Irgendwann jedoch kam es "richtig dicke" :cautious: Seit dem Versuch von Titanium Backup den Eintrag "Einstellungsspeicher" wiederherzustellen, rebootete das SHIFTphone... zeigte kurz den Sperrbildschirm und dann rebootete es erneut... und das immer und immer wieder. Ich konnte es nur durch Entnahme des Akkus stoppen. Nachdem ich ihn wieder eingesetzt und das Shiftphone gestartet habe: weiter das selbe Spiel.

Befinde mich nun also in einem Dauer-Rebootvorgang und das Gerät ist unbrauchbar. Was tun?
Wieso zur Hölle kann nicht einfach endlich mal was klappen und einfach alles vom alten Gerät wiederhergestellt werden? Ich dreh durch.
Das kann doch echt nicht so schwer sein!

Bitte erneut um Hilfe...
Sorry, da kann ich leider gar nicht weiterhelfen... :-(
 

Cetheus

Beta Tester
Jun 24, 2019
63
Gerät(e) / Device(s)
SHIFT6m
@SH1FT Ich würde dir empfehlen das ding neu aufzusetzen.
Zum wiederherstellen mit Titanium Backup ein guter Rat:
  • Ich würde nie System-Apps über TB wiederherstellen. Wie du gerade merkst, führt das zu Problemen.
    TB kann zwischen System Apps und vom User installierten Apps unterscheiden.
  • Manchmal kann es vorkommen, dass Apps nicht installiert werden können, wenn z.b. schon eine Version installiert ist.
    Wenn sich hier die Versionen unterscheiden, kann es mit den gespeicherten Daten und denen, die die App lesen/schreiben kann, zu konflikten führen.
    Daher würde ich das vor dem Wiederherstellen prüfen und ggf. die betroffene App deinstallieren.
 

Cetheus

Beta Tester
Jun 24, 2019
63
Gerät(e) / Device(s)
SHIFT6m
du kannst die vol-down taste gedrückt halten, währen du den Akku wieder einsetzt. dann sollte er in den download Modus wechseln. (wenn nicht, zusätzlich die power Taste gedrückt halten)
darüber kannst du dann mit dem Flash Tool das Image neu aufspielen.
 

SH1FT

Member
Jul 17, 2019
17
Gerät(e) / Device(s)
SHIFT5me
Danke, probiere ich aus.
Gibt's irgendwo eine Anleitung, was ich dafür im Flashtool klicken muss?
Das Flashtool-image habe ich noch wegen des rootens. Kann ich das denn auch gleich inkl. root-Zugriff machen oder erst neu aufspielen und anschließend wie bisher rooten?

Danke