(SHIFT6mq) LineageOS 18.1 (Android 11) - Vorabtest

trainman261

Beta Tester
12 September 2020
157
Den Fehler bekommst du nicht weg. Der Bootloader ist offen und LineageOS ist nicht zertifiziert.
Greetz
Müsste eigentlich wegzukriegen sein. Dazu gibt es zwei Module:
  • MagiskHide Props Config. Damit kann man die Systemkonfiguration ändern, was SafetyNet sieht und kann dem vortäuschen, es wäre ein anderes Betriebssystem.
  • Universal SafetyNet Fix. Damit kann man die Überprüfung (zumindest bis das noch geschlossen wird) hardwareseitig unterbinden, damit nur die softwareseitige Überprüfung stattfindet, die mit MagiskHide umgangen werden kann.
 

NoG....eFan

Alpha Tester
Beta Tester
14 Juli 2020
249
Hallo, heute habe ich "Seedvault" in Lineage entdeckt! Hammer, wenn es das ist was ich zu glauben meine. Habe die Sicherung auf SD-Karte gemacht, weil ich mit der Wolke nix am Hut habe. Siehe Facebook:poop:. Wenn die abstürzen dann kein ran kommen mehr. Was ich jetzt nicht ganz verstehe ist: Apps die nicht benutzt wurden, wurden mit einem Roten Ausrufezeichen versehen. Meine Frage; Werden die nicht mit gesichert? 2. Frage. Da kann ich mir doch fast Titanium sparen, oder? 3. Frage. Kann ich die Sicherung auch auf ein 2. 6mq übernehmen, wenn natürlich die selben Vorraussetzungen erfüllt sind (Hardware OS)?
 
Zuletzt bearbeitet:
  • Wow
Reaktionen: danielp

danielp

SHIFT Friend
Alpha Tester
22 September 2019
2.093
Von
bis
 

danielp

SHIFT Friend
Alpha Tester
22 September 2019
2.093
Eigentlich sind dort mehr oder weniger wenn auch vielleicht indirekt alle deine Fragen beantwortet!

1. Apps die nicht benutzt, zurückgesetzt und komischerweise auch die beendet wurden werden nicht gesichert!
2. Titanium sollte in der Lage sein jede App zu sichern, ob das jedoch sinnvoll ist steht auf einem anderen Blatt.
3. Ich denke (bin aber nicht sicher) das die Sicherung mit adb backup kompatibel ist. Damit sollte man das Backup (von Benutzerapps) auch mit adb restore wieder auf einem anderen System wiederherstellen können.
 
  • Like
Reaktionen: NoG....eFan

amartinz

ShiftOS Developer
Original poster
ShiftOS Developer
SHIFT Staff
19 März 2018
1.022
26
Wolfsberg, Austria
1. Apps die nicht benutzt, zurückgesetzt und komischerweise auch die beendet wurden werden nicht gesichert!
Wiederherstellen von gesicherten System-Apps schlägt auch fehl, wenn sie auf dem System nicht existieren.

Beispiel: Ich installiere Magisk als System-App, mach ein Backup davon.
Danach installiere ich die ROM neu, Magisk ist weg.

Lässt sich nicht wiederherstellen, obwohl es gesichert wurde.
 

@Lhotze

Alpha Tester
Beta Tester
21 Oktober 2020
304
MagiskHide Props Config. Damit kann man die Systemkonfiguration ändern, was SafetyNet sieht und kann dem vortäuschen, es wäre ein anderes Betriebssystem.
Das Modul hat seine Berechtigung. So glaubt Safety-Net bspw. nicht, dass es mit einer nicht zertifizierten LineageOS unterwegs ist, sondern mit Android 11 von nem Pixel-Gerät (oder anderen). Macht Sinn.
Universal SafetyNet Fix.
Das Modul ist unnötig. Magisk zeigt Safety-Net als bestanden an. Alle anderen Safety-Net-Checker zeigen aber nach wie vor nen Missmatch und Anwendung die Safety-Net brauchen funktionieren trotzdem nicht. Mittlerweile glaube ich, dass das Modul lediglich den Status bei Magisk faked und keinen Einfluss auf das System und Safety-Net als solches hat.
Greetz
 
  • Like
Reaktionen: NoG....eFan

amartinz

ShiftOS Developer
Original poster
ShiftOS Developer
SHIFT Staff
19 März 2018
1.022
26
Wolfsberg, Austria
Übrigens, das 6mq nutzt Device ID Attestation.
Heißt es muss was ganz spezielles gemacht bzw. nicht gemacht werden, um die Checks zu bestehen.

Mehr darf ich dazu aber nicht sagen.
 
  • Haha
Reaktionen: danielp

@Lhotze

Alpha Tester
Beta Tester
21 Oktober 2020
304
Wo befindet sich die VOLTE-Option? Man kann Volte finden in der Einstellungssuche. Wenn man dann darauf tippt, kommt nichts.
Volte und auch Wifi-call sind schon wichtig.
Hab jetzt mal ein bisschen rumprobiert.
Für LineageOS Nutzer mit Magisk kann ich das Modul aus diesem Pixel 3 Thread von XDA empfehlen. Danach läuft VoLTE.
Ob Nebeneffekte auftreten weiß ich aber noch nicht.


Greetz
 

Anhänge

  • voltefixer-signed.zip
    7,9 KB · Aufrufe: 5
  • Like
Reaktionen: Uli und NoG....eFan

NoG....eFan

Alpha Tester
Beta Tester
14 Juli 2020
249
Ich mal wieder! Nur 1 Verständnis-Frage. Ist denn in allen Versionen mit Lineage, z.B. Lineage mit MicroG, Lineage mit oder ohne G....e, auch Lineage beteiligt, oder sind das externe "Kracks und Helfer und Künstler" die da mithelfen? Bekommen diese einzelnen Vers. alle OTA Updates?
 

ymybe

Beta Tester
5 Februar 2021
38
Ich mal wieder! Nur 1 Verständnis-Frage. Ist denn in allen Versionen mit Lineage, z.B. Lineage mit MicroG, Lineage mit oder ohne G....e, auch Lineage beteiligt, oder sind das externe "Kracks und Helfer und Künstler" die da mithelfen? Bekommen diese einzelnen Vers. alle OTA Updates?
https://download.lineageos.org/axolotl/changes/ hier kannst du sehen was und dann auch wer was geaendert hat axolotl spezielle anpassungen kommen meist direkt von @amartinz , aller andere machen andere freiwillige rund um lineage. wo du deine gapps herbekommst ist dir beim sideload selbst ueberlassen, als ichs noch wollte war ich mit opengapps ganz zufrieden. OTA funktioniert bei mir leider noch nicht so ganz ich kopier mir die datei auf die SD karte und installiere von dort, keine ahnung was ich vergessen habe zu flashen, aber vielleicht gehts auch einfach noch nicht.
 
  • Like
Reaktionen: NoG....eFan

NoG....eFan

Alpha Tester
Beta Tester
14 Juli 2020
249
Und wieder ich: Mir ist aufgefallen dass das Handy unter Lineage das laden aufhört wenn die 100% erreicht sind. Ich lade ja immer die 6mq`s auf den alten Galaxy S4 Qi Ladeplatten auf, was auch tadellos klappt (trotz der dicken Oliven-Booklets. Ist das gewollt, oder ist da was kaputt:love:? Ich hatte es bisher eigentlich nicht voll geladen, weil der Ladepunkt (grün) weiterladen anzeigte obwohl bereits voll. Jetzt meine Frage; hört es dann tatsächlich zu laden auf, oder lädt es weiter obwohl voll und keine Lade-Anzeige mehr grün zeigt?
 

@Lhotze

Alpha Tester
Beta Tester
21 Oktober 2020
304
Das ist doch aber bei Shift OS-L ebenso ?!? Oder nicht
Prinzipiell ja, wobei ShiftOS ja zumindest in der G-Version ne Zertifizierung besitzt, LineageOS nicht.

Ich dachte ich hätte Safety-Net auf ShiftOS-L mal hinbekommen, bin aber mittlerweile eher der Meinung, dass ich nur den Magisk-Manager verarscht habe. Konnte das auf Android 11 (LineageOS) nicht reproduzieren, wobei hier auch zu bedenken ist, dass Google bei jeder neuen Android-Version bestrebt ist, die aktuellen Lücken in Sachen Safety-Net zu schließen.

Da Magisk derzeit nicht mehr entwickelt wird gehört Magisk-Hide der Vergangenheit an und spätestens mit Android 12 geht eh nix mehr. Kann sein, dass das auch schon mit 11 angefangen hat. Da hört mein Forscherdrang auf, da ich bisher keine Anwendung nutze, die auf Safety-Net angewiesen ist 🤷🏼‍♂️.

Greetz
 
  • Like
Reaktionen: NoG....eFan

skid42

Alpha Tester
Beta Tester
2 Juli 2020
63
Guten Morgen!
Erstmal Danke @amartinz für das großartige Lineage OS (die schnellste Umsetzung nach Official, die ich je gesehen habe ;) )

Ich erfahre auf meinem Telefon einen Bug: Wenn ich normal über das Gerät telefoniere, klinge ich auf der anderen Seite wie ein Alien. Es ist sehr leise und und es kommt verzerrt und unverständlich an.
Schalte ich die Lautsprecher Funktion an, ist es weg (klare Verständlichkeit). Stecke ich einen Kopfhörer ist es weg (das gegenüber hört ein Echo seiner selbst, ich selbst bin aber klar zu verstehen). Gehe ich auf Bluetooth, ist die Verständlichkeit klar.

Das tritt auf Nighlty 211003 und 221013 auf.
Ein Gegentest mit ShiftOS (G3.3 und L3.5) zeigt diesen Fehler nicht: Hier ist das Telefon immer klar verständlich.

Hat einer von Euch das Problem auch beobachtet?
Wäre dankbar für Rückmeldungen/Tipps.

Cheers Jochen
 
  • Like
Reaktionen: ymybe

amartinz

ShiftOS Developer
Original poster
ShiftOS Developer
SHIFT Staff
19 März 2018
1.022
26
Wolfsberg, Austria
Konnte ich so nicht feststellen, aber schau ich mir nochmal an.

Wir nutzen mit Lineage die Audio HAL von ShiftOS, ist also genau der selbe Code.
Vielleicht spielt da was nicht gut mit der neueren Android Version zusammen.

Ist dann aber komisch, dass es mir bei den Tests nicht aufgefallen ist.

Die neueren Nightlies hab ich aber nicht getestet, die werden automatisch erstellt.
 

skid42

Alpha Tester
Beta Tester
2 Juli 2020
63
Puh, eine kaputte SD-Karte und drei Stunden testen später:

Ich kann den Fehler derzeit nicht rekonstruieren (Telefonate von meinem Festnetz an das Handy klingen derzeit unverzerrt).
Mein Lösungsansatz:
Ich installiere nacheinander alle LOS-Versionen, angefagen von der unofficial über alle vier Roms die derzeit auf Lineage liegen. Alle installationen mit 211013 recovery und ohne installation von Gapps/magisk. Jeweils einmal im dirty flash getestet, danach im Recovery factory reset gemacht, getestet und die nächste Version drüber installiert.
210905: kein Problem
210922: kein Problem
210929: kein Problem
211006: Problematisch (nach reinstall: kein Problem)
211013: kein Problem

Hernach habe ich bei 211013 -
OpenGapps pico installiert und getestet - kein Problem
Magisk installiert und getestet - kein Problem

Alle Telefonate von Handy <-> Festnetz klingen unverzerrt.
Ich bin mir noch nicht klar, ob es daran liegt, dass ich den "langen weg" genommen habe, oder ob es an dem sauberen System lag.
Sollte der Fehler wieder auftreten (evtl. nach Installation aller Apps, oder wenn ich dann morgen das Handy produktiv nutze), melde ich mich mit einem update...

Erstmal Danke an Euch für das Feedback!

Sollte der Fehler wieder auftreten (evtl. nach Installation aller Apps, oder wenn ich dann morgen das Handy produktiv nutze), melde ich mich mit einem update...
Guten Morgen,

also wie versprochen, das update: gleich der erste Anruf hat das Phänomen repliziert. Sprachverständlichkeit über internes Mikrofon = null, per Lautsprecher geht's
Basis:
LOS 211013, OpenGapps pico (arm64,11.0), Magistv23 - sowie die installierten Apps aus dem Playstore.
Es fällt auf, dass die Einblendung des Dialers sehr spät nach Beginn des Klingelns erfolgt.

Update2:
Ich habe mal was skurriles ausprobiert:
Installiertes Rom = 210905 unofficial (plus OpenGappspico) + Magisk gepatchter Bootloader von 211013. Hier tritt der Fehler ebenfalls auf.
Danach den Magisk gepatchten Bootloader von 210905 unofficial drübergeflasht und factory reset: Sprachverständlichkeit wieder da (bis jetzt).

Ich probiere das in dieser Config mal über den Tag aus, ob das stabil bleibt (übrigens: Dialer kommt be anruf sofort auf den Bildschirm, nicht mit Verzögerung wie bei 211013)...

Update3:
Der Fehler tritt mittlerweile auch bei der heute morgen noch funktionierenden Konfiguration (210905-Gapps-Magisk) auf.
 
  • Like
Reaktionen: amartinz